• Najnowsze pytania
  • Bez odpowiedzi
  • Zadaj pytanie
  • Kategorie
  • Tagi
  • Zdobyte punkty
  • Ekipa ninja
  • IRC
  • FAQ
  • Regulamin
  • Książki warte uwagi

Problem z działaniem testu Junit

Object Storage Arubacloud
+1 głos
745 wizyt
pytanie zadane 16 października 2021 w Java przez p_wika Nowicjusz (190 p.)

Hejka, mam pytanie dlaczego wyskakuje mi następujący błąd przy próbie uruchomienia testu jednostkowego. Załączam plik pom.xml

błąd: Internal Error occurred.
org.junit.platform.commons.JUnitException: TestEngine with ID 'junit-vintage' failed to discover tests
    at org.junit.platform.launcher.core.DefaultLauncher.discoverEngineRoot(DefaultLauncher.java:189)
    at org.junit.platform.launcher.core.DefaultLauncher.discoverRoot(DefaultLauncher.java:168)
    at org.junit.platform.launcher.core.DefaultLauncher.execute(DefaultLauncher.java:132)
    at com.intellij.junit5.JUnit5IdeaTestRunner.startRunnerWithArgs(JUnit5IdeaTestRunner.java:71)
    at com.intellij.rt.junit.IdeaTestRunner$Repeater.startRunnerWithArgs(IdeaTestRunner.java:33)
    at com.intellij.rt.junit.JUnitStarter.prepareStreamsAndStart(JUnitStarter.java:220)
    at com.intellij.rt.junit.JUnitStarter.main(JUnitStarter.java:53)
Caused by: org.junit.platform.commons.JUnitException: Failed to parse version of junit:junit: 4.13.2

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0"
         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>

    <groupId>org.example</groupId>
    <artifactId>Zadanie7</artifactId> <!--  -->
    <version>1.0-SNAPSHOT</version>

    <!-- Podajemy z jakiej i do jakiej wersji java kompilujemy zrodlo -->
    <properties>
        <maven.compiler.source>15</maven.compiler.source>
        <maven.compiler.target>15</maven.compiler.target>
    </properties>

    <!-- Konfiguracja builda -->
    <build>
        <pluginManagement>
            <plugins>
                <plugin>
                    <groupId>org.apache.maven.plugins</groupId>
                    <artifactId>maven-compiler-plugin</artifactId>
                    <version>3.8.1</version>
                </plugin>
            </plugins>
        </pluginManagement>
    </build>

    <!-- dodajemy zaleznosc Junit do pisania testow jednostkowych -->
    <dependencies>
        <dependency>
            <groupId>org.junit.jupiter</groupId>
            <artifactId>junit-jupiter</artifactId>
            <version>5.6.0</version>
            <!-- scope zapewnia dostep do biblioteki tylko w folderze test -->
            <scope>test</scope>
        </dependency>
    </dependencies>

</project>

 

komentarz 16 października 2021 przez tkz Nałogowiec (42,020 p.)
Brakuje zależności dla vintage engine. Poszukaj w necie jak ją dodać.
komentarz 16 października 2021 przez Wiciorny Ekspert (273,810 p.)
tkz, odwrotnie kolega korzysta z JUnita więc lepiej zrobić exclude :) bo z Jupiterem 5tką potem i tak bedą problemy.

1 odpowiedź

+1 głos
odpowiedź 16 października 2021 przez Wiciorny Ekspert (273,810 p.)
<dependency>
    <groupId>org.springframework.boot</groupId>
    <artifactId>spring-boot-starter-test</artifactId>
    <scope>test</scope>
    <exclusions>
        <exclusion>
            <groupId>org.junit.vintage</groupId>
            <artifactId>junit-vintage-engine</artifactId>
        </exclusion>
    </exclusions>
</dependency>

Dodaj zależnosć springboot starter test - on domyślnie korzystać będzie z tego czego potrzebujesz,

dodatkowo wyłącz pakiet vintage- bo w tej wersji nie jest wspierany i jest niepotrzebny w ramach pracy z Junitem 

Ewentulanie jeśli dalej problem w pakietach będzie występował wtedy pozostaw JUPITERA i tak jak @tkz napisał dodaj zależność 

<dependency>
    <groupId>org.junit.vintage</groupId>
    <artifactId>junit-vintage-engine</artifactId>
    <version>5.7.0</version>
</dependency>

czego ostatecznie nie polecam i raczej lepiej stosować jedną zależność bo potem będą kolizje biblioteczne 

1
komentarz 16 października 2021 przez p_wika Nowicjusz (190 p.)
Super, już działa, dzięki bardzo :)

Podobne pytania

0 głosów
1 odpowiedź 398 wizyt
pytanie zadane 4 maja 2021 w Java przez janyczek Początkujący (360 p.)
0 głosów
2 odpowiedzi 611 wizyt
pytanie zadane 29 lutego 2020 w Java przez StressedOut Nowicjusz (210 p.)
0 głosów
1 odpowiedź 154 wizyt
pytanie zadane 3 sierpnia 2018 w Java przez kamil159 Nowicjusz (180 p.)

92,760 zapytań

141,684 odpowiedzi

320,470 komentarzy

62,104 pasjonatów

Motyw:

Akcja Pajacyk

Pajacyk od wielu lat dożywia dzieci. Pomóż klikając w zielony brzuszek na stronie. Dziękujemy! ♡

Oto polecana książka warta uwagi.
Pełną listę książek znajdziesz tutaj.

Akademia Sekuraka

Niedawno wystartował dodruk tej świetnej, rozchwytywanej książki (około 940 stron). Mamy dla Was kod: pasja (wpiszcie go w koszyku), dzięki któremu otrzymujemy 10% zniżki - dziękujemy zaprzyjaźnionej ekipie Sekuraka za taki bonus dla Pasjonatów! Książka to pierwszy tom z serii o ITsec, który łagodnie wprowadzi w świat bezpieczeństwa IT każdą osobę - warto, polecamy!

...