• Najnowsze pytania
  • Bez odpowiedzi
  • Zadaj pytanie
  • Kategorie
  • Tagi
  • Zdobyte punkty
  • Ekipa ninja
  • IRC
  • FAQ
  • Regulamin
  • Książki warte uwagi

Nie dzialajace IDE linux

Object Storage Arubacloud
0 głosów
164 wizyt
pytanie zadane 13 stycznia 2017 w Java przez 0xf Dyskutant (8,180 p.)
#java #coredumped
Uzywam apricity OS opartego na archu.
Zainstalowalem dopiero co spotify ale gdy go odpalam i sie loguje to wylacza mi najzwyczajniej okienko. Odpalilem w terminalu i mam takie logi http://pastebin.com/QH4jzzWJ
Podobny problem mam z intellij kiedy odpalam mam cos takiego:

marcel  ~  intellij-idea-ultimate-edition

Unsupported Java Version: Cannot start under Java 1.7.0_111-b01: Java 1.8 or later is required.
Nie rozumiem dlaczego gdyz jdk8-openjdk dopiero co instalowalem instalowalem tez jdk8-openjdk-jetbrains z AUR
Co zrobic ze swoim zyciem?
komentarz 13 stycznia 2017 przez adrian17 Ekspert (346,320 p.)

Co zrobic ze swoim zyciem?

Pobierz dystrybucję przyjaźniejszą dla niezaawansowanych.

komentarz 13 stycznia 2017 przez niezalogowany
A wtedy się dowiesz, że jesteś Gupi, bo gdybyś używał hakerskiej to by ci działało :)

Prawda jest taka, że od żadnego linuksa nie można oczekiwać stabilności czy poprawności działania.

Co do pytania głównego, może nie działa z OpenJDK? Próbowałeś prawdziwą oraclową? Poza tym, komunikat sugeruje, że masz jednak 1.7 i ją właśnie woła ten program. Nie masz dwóch wersji?
komentarz 13 stycznia 2017 przez 0xf Dyskutant (8,180 p.)
Co prawda to prawda zaczyna mnie denerwowac linux ale zeby robic cos na windowsie to nie mysle bo pisanie w javie na windzie ujdzie ale taki c++ gdzie doinstalowanie jakiegos frameworka to 3 godziny klikania to az mnie ciary przechodza. Musze w koncu dojrzec i sobie hacka postawic ale chyba za krotki na to jestem :(
komentarz 13 stycznia 2017 przez adrian17 Ekspert (346,320 p.)
Bo siedzisz na słabo wspieranym OSie którego filozofią jest żeby dużo robić samodzielnie.

Tymczasem Spotify ma oficjalne buildy na Debiana i Ubuntu:

https://www.spotify.com/pl/download/linux/
komentarz 13 stycznia 2017 przez 0xf Dyskutant (8,180 p.)
Nie siedze na tych systemach bo zawsze mi sie cos na nich sypalo :(
komentarz 13 stycznia 2017 przez 0xf Dyskutant (8,180 p.)
Na ubuntu dosyc czesto po updatach nie ladowal mi sie juz ekran
komentarz 13 stycznia 2017 przez 0xf Dyskutant (8,180 p.)
moglbym sie przerzucic na debiana tylko bardzo bym chcial zachowac takie samo gui jak ma apricity OS niby ma gnoma ale gnome na debianie a gnome na apricity wyglada zupelnie inaczej
1
komentarz 13 stycznia 2017 przez manjaro Nałogowiec (37,390 p.)

Prawda jest taka, że od żadnego linuksa nie można oczekiwać stabilności czy poprawności działania.

Prawda jest taka ze to propaganda iście w stylu TVN. Trudno o większe kłamstwo. Raczej od żadnego windowsa nie można oczekiwać stabilności. Poza tym co ma wspólnego program ze stabilnością systemu? Ten program nie jest częścią systemu. Nie ma go w oficjalnym repozytorium Archa. Został pobrany z AUR co znaczy że został kiedyś tam skompilowany przez kogoś tam i udostępniony w nieoficjalnym repozytorium społeczności. Coś jak google play na Androidzie. Nikt nie ma kontroli nad tym co tam trafia. Tak więc panie Śmiejek jak pan nie ma pojęcia o czymś to niech pan głosu nie zabiera bo się pan kompromituje.

1 odpowiedź

0 głosów
odpowiedź 13 stycznia 2017 przez manjaro Nałogowiec (37,390 p.)
A po co instalujesz z AUR? W domyślnym repo nie ma nowszej javy?

Sprawdź w ogóle jaką masz tą javę
java -version

Jeżeli to jest jakaś pochodna Archa to zakładam że ma pacmana. Spróbuj zainstalować javę poprzez
pacman -S jdk8-openjdk

Ewentualnie radzę zainstalować czystego Archa. U mnie na Archu spotify śmiga aż miło. Pozdrawiam
komentarz 13 stycznia 2017 przez 0xf Dyskutant (8,180 p.)
Juz dziala intellij ale spotify nie.
komentarz 13 stycznia 2017 przez manjaro Nałogowiec (37,390 p.)
Bardzo możliwe że to wina samego spotify. Też tak kiedyś miałem identycznie. Po aktualizacji wszystko wróciło do normy.

Instalacja z AUR nie zawsze jest w pełni kompatybilna z systemem.

Ja mam aktualnie taką wersję i działa prawidłowo

aur/spotify 1.0.45.186-1 [installed]

Pamiętaj również o aktualizacjach paczek z AUR poprzez

yaourt -Syua

Podobne pytania

+1 głos
1 odpowiedź 988 wizyt
+4 głosów
1 odpowiedź 482 wizyt
pytanie zadane 5 lutego 2021 w Java przez Anedroid Obywatel (1,530 p.)
0 głosów
1 odpowiedź 443 wizyt
pytanie zadane 4 października 2015 w C# przez 0xf Dyskutant (8,180 p.)

92,677 zapytań

141,581 odpowiedzi

320,061 komentarzy

62,039 pasjonatów

Motyw:

Akcja Pajacyk

Pajacyk od wielu lat dożywia dzieci. Pomóż klikając w zielony brzuszek na stronie. Dziękujemy! ♡

Oto polecana książka warta uwagi.
Pełną listę książek znajdziesz tutaj.

Akademia Sekuraka

Niedawno wystartował dodruk tej świetnej, rozchwytywanej książki (około 940 stron). Mamy dla Was kod: pasja (wpiszcie go w koszyku), dzięki któremu otrzymujemy 10% zniżki - dziękujemy zaprzyjaźnionej ekipie Sekuraka za taki bonus dla Pasjonatów! Książka to pierwszy tom z serii o ITsec, który łagodnie wprowadzi w świat bezpieczeństwa IT każdą osobę - warto, polecamy!

...