• Najnowsze pytania
  • Bez odpowiedzi
  • Zadaj pytanie
  • Kategorie
  • Tagi
  • Zdobyte punkty
  • Ekipa ninja
  • IRC
  • FAQ
  • Regulamin
  • Książki warte uwagi

[Excel] Zliczenie sprzedaży opartę o nazwy firm

Object Storage Arubacloud
0 głosów
147 wizyt
pytanie zadane 9 sierpnia 2023 w Rozwój zawodowy, nauka, praca przez KonDZIKs Bywalec (2,770 p.)

Witam.
Mam do zrobienia zadanie i napotkałem pewien problem. Mam do policzenia ilość kupna poszczególnych firm.
Pokaże tabelki o co chodzi.


Próbowałem licz.jeżeli, suma.jeżeli, suma.warunku. Jak wydawało mi się, że powinno być dobrze to zawsze zwracało 0... Nie wiem gdzie popełniam błąd jak dałem licz.jeżeli to zliczyło mi ale sume wystąpień wszystkich a nie tylko dla danej firmy (wiem dlaczego tak sie działo. Testowałem czy cokolwiek wgl chce działać.

Jest jakaś funkcja, którą ja pominąłem? Czy ja coś w tych funkcjach których użyłem popełniłem bład?

 

1 odpowiedź

+2 głosów
odpowiedź 9 sierpnia 2023 przez manjaro Nałogowiec (37,390 p.)
wybrane 10 sierpnia 2023 przez KonDZIKs
 
Najlepsza

Spróbuj LICZ.WARUNKI

=LICZ.WARUNKI($C$4:$C$12;"x";$D$4:$D$12;"Buy")

1
komentarz 9 sierpnia 2023 przez KonDZIKs Bywalec (2,770 p.)
Dziękuję. Ja robiłem na odwrót najpierw transakcja później firma
komentarz 9 sierpnia 2023 przez KonDZIKs Bywalec (2,770 p.)

A teraz mam pytanie. Bo mam jeszcze kolumnę koszt całkowity liczony z kolumn (ilośc * cena). Mam teraz wyliczyć średnią cenę to mogę dodać do tego kolejny warunek? Aby zliczyć zysk całkowity. Czyli
=llicz.warunki(przedział firm; nazwa firmy; typy transakcji; typ transakcji;cena całkowita; Tylko nie wiem jaki dać tutaj drugi warunek) czy to jest trochę bez sensu? Ale trzeba użyć tych wcześniejszych warunków żeby było wiadaomo jakie kwoty pobrać

2
komentarz 9 sierpnia 2023 przez manjaro Nałogowiec (37,390 p.)
edycja 9 sierpnia 2023 przez manjaro
Podobnie,

=ŚREDNIA.WARUNKÓW($E$4:$E$12;$C$4:$C$12;"x";$D$4:$D$12;"Buy")
komentarz 10 sierpnia 2023 przez KonDZIKs Bywalec (2,770 p.)
Dzięki :D
komentarz 10 sierpnia 2023 przez KonDZIKs Bywalec (2,770 p.)

Mam jeszcze pytanie. Musze wskazać firmę z największym zyskiem używam do tego formuły Max. Wynik jest podawany w liczbie jak mogę zrobić aby zamienić liczbę na nazwę firmy? Próbowałem z wyszukaj pionowo
=WYSZUKAJ.PIONOWO(MAX(E47;E47:E86);D47:D86;1;0)
ale to nie zadziałało. Myślałem też nad suma warunków ale mi nie potrzebna jest suma. Myślałem jeszcze nad indeksem ale to raczej zły pomysł

2
komentarz 10 sierpnia 2023 przez manjaro Nałogowiec (37,390 p.)
Wyszukaj pionowo zadziała ale jak zamienisz miejscami kolumny Firma oraz zysk.

Ale to zadziała:

=INDEKS(C4:C6;PODAJ.POZYCJĘ(MAKS(D4:D6);D4:D6;0))
1
komentarz 11 sierpnia 2023 przez KonDZIKs Bywalec (2,770 p.)
Dziękuję jeszcze raz :D

Podobne pytania

0 głosów
0 odpowiedzi 92 wizyt
0 głosów
0 odpowiedzi 572 wizyt
0 głosów
0 odpowiedzi 173 wizyt
pytanie zadane 10 marca 2021 w Rozwój zawodowy, nauka, praca przez hacerberry Użytkownik (670 p.)

92,682 zapytań

141,585 odpowiedzi

320,071 komentarzy

62,042 pasjonatów

Motyw:

Akcja Pajacyk

Pajacyk od wielu lat dożywia dzieci. Pomóż klikając w zielony brzuszek na stronie. Dziękujemy! ♡

Oto polecana książka warta uwagi.
Pełną listę książek znajdziesz tutaj.

Akademia Sekuraka

Niedawno wystartował dodruk tej świetnej, rozchwytywanej książki (około 940 stron). Mamy dla Was kod: pasja (wpiszcie go w koszyku), dzięki któremu otrzymujemy 10% zniżki - dziękujemy zaprzyjaźnionej ekipie Sekuraka za taki bonus dla Pasjonatów! Książka to pierwszy tom z serii o ITsec, który łagodnie wprowadzi w świat bezpieczeństwa IT każdą osobę - warto, polecamy!

...