• Najnowsze pytania
  • Bez odpowiedzi
  • Zadaj pytanie
  • Kategorie
  • Tagi
  • Zdobyte punkty
  • Ekipa ninja
  • IRC
  • FAQ
  • Regulamin
  • Książki warte uwagi

question-closed Exception podczas uruchomienia aplikacji .net asp

0 głosów
47 wizyt
pytanie zadane 26 września 2021 w C# przez ShockWave Bywalec (2,320 p.)
zamknięte 27 września 2021 przez ShockWave

Cześć, mam problem, ponieważ podczas podłączania bazy danych entity, wyskakuje mi błąd o komunikacie jak na zdjęciu.

Z góry dziękuję i pozdrawiam.

komentarz zamknięcia: Trzeba pod serwer  podstawić .\\SQLEXPRESSS
komentarz 26 września 2021 przez Wiciorny Mędrzec (197,420 p.)
wrzuć ten fragment kodu.
komentarz 26 września 2021 przez ShockWave Bywalec (2,320 p.)
services.AddDbContext<ApplicationDbContext>(x => 
                x.UseSqlServer(Configuration.GetConnectionString("Default")));

 

komentarz 26 września 2021 przez ShockWave Bywalec (2,320 p.)
public class ApplicationDbContext : DbContext
    {
        public DbSet<MessageEntity> Messeges { get; set; }

        public ApplicationDbContext(DbContextOptions<ApplicationDbContext> options) : base(options)
        {
                
        }
    }

 

komentarz 26 września 2021 przez ShockWave Bywalec (2,320 p.)
public class MessageEntity
    {
        public int Id { get; set; }

        public string Content { get; set; }
        public string FirstNameAuthor { get; set; }

        public string LastNameAuthor { get; set; }
    }

 

komentarz 26 września 2021 przez kubaapk Nałogowiec (44,490 p.)
Pokaż jeszcze appsettings.json.
komentarz 26 września 2021 przez Wiciorny Mędrzec (197,420 p.)
jak zdefiniowaną masz defultową configuracje połączenia w  appsettings.json ?
Bo pobierasz "default" a zwracana jest null- > brak wartości
komentarz 26 września 2021 przez ShockWave Bywalec (2,320 p.)
{
  "ConnectionString": {
    "Default": "Server=.;Database=ASP;Trusted_Connection=True;"
  },
  "Logging": {
    "LogLevel": {
      "Default": "Information",
      "Microsoft": "Warning",
      "Microsoft.Hosting.Lifetime": "Information"
    }
  },
  "Application": {
    "RefreshTime": 1000
  }
}

 

komentarz 26 września 2021 przez Wiciorny Mędrzec (197,420 p.)

  "Default": "Server=.;Database=ASP;Trusted_Connection=True;"

nie jest ustawiony... to dlatego
 https://docs.microsoft.com/en-us/dotnet/framework/data/adonet/connection-strings-and-configuration-files

Server jest pusty...  dla przykładu powinieneś mieć coś podobnego. 
https://docs.microsoft.com/en-us/aspnet/core/fundamentals/configuration/?view=aspnetcore-5.0

"DefaultConnection": "Server=(localdb)\\mssqllocaldb;Database=aspnet-
WebApplica71d622;Trusted_Connection=True;MultipleActiveResultSets=true"

 

komentarz 26 września 2021 przez ShockWave Bywalec (2,320 p.)

Wstawiłem pod server "localhost\SQLEXPRESS" teraz mam inn błąd.

komentarz 27 września 2021 przez ShockWave Bywalec (2,320 p.)
Trzeba pod serwer podstawić po prostu .\\SQLEXPRESS

Podobne pytania

+1 głos
2 odpowiedzi 119 wizyt
pytanie zadane 20 sierpnia 2021 w C# przez dawid2002 Mądrala (5,160 p.)
–4 głosów
1 odpowiedź 539 wizyt
0 głosów
0 odpowiedzi 200 wizyt

86,485 zapytań

135,241 odpowiedzi

300,484 komentarzy

57,233 pasjonatów

Motyw:

Akcja Pajacyk

Pajacyk od wielu lat dożywia dzieci. Pomóż klikając w zielony brzuszek na stronie. Dziękujemy! ♡

Oto dwie polecane książki warte uwagi. Pełną listę znajdziesz tutaj.

...