• Najnowsze pytania
  • Bez odpowiedzi
  • Zadaj pytanie
  • Kategorie
  • Tagi
  • Zdobyte punkty
  • Ekipa ninja
  • IRC
  • FAQ
  • Regulamin
  • Książki warte uwagi

question-closed Exception podczas uruchomienia aplikacji .net asp

0 głosów
43 wizyt
pytanie zadane 26 września w C# przez ShockWave Bywalec (2,250 p.)
zamknięte 27 września przez ShockWave

Cześć, mam problem, ponieważ podczas podłączania bazy danych entity, wyskakuje mi błąd o komunikacie jak na zdjęciu.

Z góry dziękuję i pozdrawiam.

komentarz zamknięcia: Trzeba pod serwer  podstawić .\\SQLEXPRESSS
komentarz 26 września przez Wiciorny Mędrzec (186,250 p.)
wrzuć ten fragment kodu.
komentarz 26 września przez ShockWave Bywalec (2,250 p.)
services.AddDbContext<ApplicationDbContext>(x => 
                x.UseSqlServer(Configuration.GetConnectionString("Default")));

 

komentarz 26 września przez ShockWave Bywalec (2,250 p.)
public class ApplicationDbContext : DbContext
    {
        public DbSet<MessageEntity> Messeges { get; set; }

        public ApplicationDbContext(DbContextOptions<ApplicationDbContext> options) : base(options)
        {
                
        }
    }

 

komentarz 26 września przez ShockWave Bywalec (2,250 p.)
public class MessageEntity
    {
        public int Id { get; set; }

        public string Content { get; set; }
        public string FirstNameAuthor { get; set; }

        public string LastNameAuthor { get; set; }
    }

 

komentarz 26 września przez kubaapk Nałogowiec (44,490 p.)
Pokaż jeszcze appsettings.json.
komentarz 26 września przez Wiciorny Mędrzec (186,250 p.)
jak zdefiniowaną masz defultową configuracje połączenia w  appsettings.json ?
Bo pobierasz "default" a zwracana jest null- > brak wartości
komentarz 26 września przez ShockWave Bywalec (2,250 p.)
{
  "ConnectionString": {
    "Default": "Server=.;Database=ASP;Trusted_Connection=True;"
  },
  "Logging": {
    "LogLevel": {
      "Default": "Information",
      "Microsoft": "Warning",
      "Microsoft.Hosting.Lifetime": "Information"
    }
  },
  "Application": {
    "RefreshTime": 1000
  }
}

 

komentarz 26 września przez Wiciorny Mędrzec (186,250 p.)

  "Default": "Server=.;Database=ASP;Trusted_Connection=True;"

nie jest ustawiony... to dlatego
 https://docs.microsoft.com/en-us/dotnet/framework/data/adonet/connection-strings-and-configuration-files

Server jest pusty...  dla przykładu powinieneś mieć coś podobnego. 
https://docs.microsoft.com/en-us/aspnet/core/fundamentals/configuration/?view=aspnetcore-5.0

"DefaultConnection": "Server=(localdb)\\mssqllocaldb;Database=aspnet-
WebApplica71d622;Trusted_Connection=True;MultipleActiveResultSets=true"

 

komentarz 26 września przez ShockWave Bywalec (2,250 p.)

Wstawiłem pod server "localhost\SQLEXPRESS" teraz mam inn błąd.

komentarz 27 września przez ShockWave Bywalec (2,250 p.)
Trzeba pod serwer podstawić po prostu .\\SQLEXPRESS

Podobne pytania

+1 głos
2 odpowiedzi 113 wizyt
–4 głosów
1 odpowiedź 501 wizyt
0 głosów
0 odpowiedzi 196 wizyt

85,805 zapytań

134,588 odpowiedzi

298,788 komentarzy

56,698 pasjonatów

Advent of Code 2021

Top 15 użytkowników

  1. 494p. - rucin93
  2. 463p. - nidomika
  3. 431p. - CC PL
  4. 385p. - Whistleroosh
  5. 379p. - ScriptyChris
  6. 372p. - adrian17
  7. 340p. - TheLukaszNs
  8. 339p. - WhiskeyTaster
  9. 321p. - Argeento
  10. 318p. - Dagohar
  11. 287p. - Anonim 1794483
  12. 281p. - Klaudia
  13. 278p. - B4mbus
  14. 269p. - b0mbix
  15. 246p. - tokox
Szczegóły i pełne wyniki

Motyw:

Akcja Pajacyk

Pajacyk od wielu lat dożywia dzieci. Pomóż klikając w zielony brzuszek na stronie. Dziękujemy! ♡

Oto dwie polecane książki warte uwagi. Pełną listę znajdziesz tutaj.

...