• Najnowsze pytania
  • Bez odpowiedzi
  • Zadaj pytanie
  • Kategorie
  • Tagi
  • Zdobyte punkty
  • Ekipa ninja
  • IRC
  • FAQ
  • Regulamin
  • Książki warte uwagi

Python, błąd podczas instalacji biblioteki PTAN: Could not find a version that satisfies the requirement torch==1.3.0

VPS Starter Arubacloud
0 głosów
380 wizyt
pytanie zadane 13 grudnia 2020 w Python przez Aqua 4 Gaduła (3,220 p.)

Podczas instalowania biblioteki do uczenia przez wzmacnianie PTAN pojawił się problem. Po uruchomieniu w terminalu polecenia:

sudo python3 -m pip install ptan==0.6

pojawia się komunikat, że wystąpił błąd i nie można zainstalować biblioteki:

ERROR: Could not find a version that satisfies the requirement torch==1.3.0 (from ptan==0.6) (from versions: 0.1.2, 0.1.2.post1, 0.1.2.post2, 1.4.0, 1.5.0, 1.5.1, 1.6.0, 1.7.0, 1.7.1)
ERROR: No matching distribution found for torch==1.3.0 (from ptan==0.6)

Podczas instalacji wersji ptan==0.4 wszystko przebiega normalnie, podobnie jak podczas instacji najnowszego PyTorcha. Niestety - potrzebuję najnowszej wersji biblioteki. Dodam też, że sytuacja wygląda tak samo podczas instalowania przez pipenv. Jak rozwiązać problem? Z góry dziękuję.

komentarz 13 grudnia 2020 przez Aqua 4 Gaduła (3,220 p.)
Nie próbowałem jeszcze instalować przez condę, czy to może pomóc?
komentarz 13 grudnia 2020 przez Nelson89 Dyskutant (7,720 p.)

Cześć!

masz już zainstalowany moduł torch? Bo ja nie miałem zainstalowanego tego modułu, przez to podczas instalacji ptan (z wykorzystaniem pip) zostały pobrane zależności w odpowiednich wersjach. W drugim teście, to zainstalowałem sobie torch w wersji 1.1.X, a następnie zainstalowałem ptan w wersji 0.6. Zależności zostały automatycznie dopasowane - po tym zabiegu torch był już w wersji 1.3.

Dlatego jestem ciekaw czy masz już torch zainstalowane i jak to instalowałeś?

Z condą możesz spróbować, możesz też spróbować instalacji ze źródła.

Używasz wirtualnego środowiska (venv, virtualenv)?

Pozdrawiam,

Nelson

komentarz 14 grudnia 2020 przez Aqua 4 Gaduła (3,220 p.)
Problem polegał na tym, że wymagany torch nie był zgodny z moją wersją Pythona (miałem 3.8, a stary torch wymagał 3.6). Twoja odpowiedź mnie na to naprowadziła, więc dziękuję.

Zaloguj lub zarejestruj się, aby odpowiedzieć na to pytanie.

Podobne pytania

0 głosów
2 odpowiedzi 806 wizyt
pytanie zadane 2 listopada 2022 w Python przez manager96 Bywalec (2,050 p.)
+1 głos
1 odpowiedź 3,368 wizyt
pytanie zadane 14 maja 2020 w Python przez Arcturus Bywalec (2,370 p.)

92,782 zapytań

141,712 odpowiedzi

320,605 komentarzy

62,115 pasjonatów

Motyw:

Akcja Pajacyk

Pajacyk od wielu lat dożywia dzieci. Pomóż klikając w zielony brzuszek na stronie. Dziękujemy! ♡

Oto polecana książka warta uwagi.
Pełną listę książek znajdziesz tutaj.

Akademia Sekuraka

Niedawno wystartował dodruk tej świetnej, rozchwytywanej książki (około 940 stron). Mamy dla Was kod: pasja (wpiszcie go w koszyku), dzięki któremu otrzymujemy 10% zniżki - dziękujemy zaprzyjaźnionej ekipie Sekuraka za taki bonus dla Pasjonatów! Książka to pierwszy tom z serii o ITsec, który łagodnie wprowadzi w świat bezpieczeństwa IT każdą osobę - warto, polecamy!

...