• Najnowsze pytania
  • Bez odpowiedzi
  • Zadaj pytanie
  • Kategorie
  • Tagi
  • Zdobyte punkty
  • Ekipa ninja
  • IRC
  • FAQ
  • Regulamin
  • Książki warte uwagi

Ruby on rails - nie moge zainstalowac bootstrapa.

Object Storage Arubacloud
0 głosów
428 wizyt
pytanie zadane 16 października 2020 w Ruby przez belkocik Początkujący (330 p.)

Czesc, próbuje zainstalować bootstrapa, lecz nie moge sie z tym uporac. wyskakuje mi blad:

Fetching sassc 2.4.0
Installing sassc 2.4.0 with native extensions
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory:
C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/sassc-2.4.0/ext
C:/RailsInstaller/Ruby2.3.3/bin/ruby.exe -r ./siteconf20201016-12812-1hsmgm1.rb
extconf.rb
creating Makefile

current directory:
C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/sassc-2.4.0/ext
make "DESTDIR=" clean

current directory:
C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/sassc-2.4.0/ext
make "DESTDIR="
compiling ./libsass/src/ast.cpp
compiling ./libsass/src/ast2c.cpp
compiling ./libsass/src/ast_fwd_decl.cpp
compiling ./libsass/src/ast_sel_cmp.cpp
compiling ./libsass/src/ast_sel_super.cpp
compiling ./libsass/src/ast_sel_unify.cpp
compiling ./libsass/src/ast_sel_weave.cpp
compiling ./libsass/src/ast_selectors.cpp
compiling ./libsass/src/ast_supports.cpp
compiling ./libsass/src/ast_values.cpp
compiling ./libsass/src/backtrace.cpp
compiling ./libsass/src/base64vlq.cpp
compiling ./libsass/src/bind.cpp
compiling ./libsass/src/c2ast.cpp
compiling ./libsass/src/c99func.c
compiling ./libsass/src/cencode.c
compiling ./libsass/src/check_nesting.cpp
compiling ./libsass/src/color_maps.cpp
compiling ./libsass/src/constants.cpp
compiling ./libsass/src/context.cpp
compiling ./libsass/src/cssize.cpp
compiling ./libsass/src/emitter.cpp
compiling ./libsass/src/environment.cpp
compiling ./libsass/src/error_handling.cpp
compiling ./libsass/src/eval.cpp
compiling ./libsass/src/eval_selectors.cpp
compiling ./libsass/src/expand.cpp
compiling ./libsass/src/extender.cpp
compiling ./libsass/src/extension.cpp
compiling ./libsass/src/file.cpp
compiling ./libsass/src/fn_colors.cpp
compiling ./libsass/src/fn_lists.cpp
compiling ./libsass/src/fn_maps.cpp
compiling ./libsass/src/fn_miscs.cpp
compiling ./libsass/src/fn_numbers.cpp
compiling ./libsass/src/fn_selectors.cpp
compiling ./libsass/src/fn_strings.cpp
./libsass/src/fn_strings.cpp: In function 'Sass::PreValue*
Sass::Functions::str_insert(Sass::Env&, Sass::Env&, Sass::Context&,
Sass::Signature, Sass::SourceSpan, Sass::Backtraces&, Sass::SelectorStack,
Sass::SelectorStack)':
./libsass/src/fn_strings.cpp:105:19: error: 'to_string' is not a member of 'std'
./libsass/src/fn_strings.cpp: In function 'Sass::PreValue*
Sass::Functions::str_slice(Sass::Env&, Sass::Env&, Sass::Context&,
Sass::Signature, Sass::SourceSpan, Sass::Backtraces&, Sass::SelectorStack,
Sass::SelectorStack)':
./libsass/src/fn_strings.cpp:177:19: error: 'to_string' is not a member of 'std'
./libsass/src/fn_strings.cpp:195:19: error: 'to_string' is not a member of 'std'
make: *** [fn_strings.o] Error 1

make failed, exit code 2

Gem files will remain installed in
C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/sassc-2.4.0 for inspection.
Results logged to
C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/extensions/x86-mingw32/2.3.0/sassc-2.4.0/gem_make.out

An error occurred while installing sassc (2.4.0), and Bundler cannot continue.
Make sure that `gem install sassc -v '2.4.0' --source 'https://rubygems.org/'`
succeeds before bundling.

In Gemfile:
  sassc-rails was resolved to 2.1.2, which depends on
    sassc

Jakis problem z sassc 2.4.0 jest. Mam ruby 2.3.3p222 Rails 5.2.4.4 zainstalowane z railsinstaller.org. 

Moje gemy

gem 'rails'
gem 'sqlite3', '< 1.4'
gem 'puma', '~> 3.7'
gem 'sass-rails'
gem 'uglifier', '>= 1.3.0'
gem 'jquery-rails'
gem 'coffee-rails', '~> 4.2'
gem 'turbolinks', '~> 5'
gem 'jbuilder', '~> 2.5'
gem 'webpack-rails', '~> 0.9.11'
gem 'sassc', '~> 2.4'
gem 'sassc-rails', '~> 2.1', '>= 2.1.2'

Z tego poradnika probuje https://www.digitalocean.com/community/tutorials/how-to-add-bootstrap-to-a-ruby-on-rails-application chcacy zainstalowac webpack to wtedy musial zainstalowac sassc 2.4.0 i wszystko sie wykrzaczylo

1
komentarz 19 października 2020 przez Bantu Nałogowiec (34,170 p.)
Brakuje Ci jakieś biblioteki, która jest używana do kompilacji gema `sassc` niestety więcej nie jestem w stanie pomóc, bo z Windowsem od lat nie miałem do czynienia. Ogólnie development apek w Rails na Windows to strasznie trudna sprawa, bo wiecznie coś nie działa, lepiej przesiąść się na jakiegoś Linuxa.
komentarz 20 października 2020 przez belkocik Początkujący (330 p.)
Dzieki za interesowanie, jakos udalo sie zainstalowac najnowsza wersje ruby i dziala na git bashu i powershellu. Caly dzien spedzilem na instalowaniu, sprawdzaniu czy dziala, pytaniu sie na stacku co zrobic, zmienianiu sciezek PATH itp. itd. i nic. Dzisaj siadlem zainstowalem najnowszego ruby bo niektore metody mi nie dzialaly przy robieniu zadan domowych i dziala pieknie - MAGIA. Ciekawe do jakiego czasu.
komentarz 20 października 2020 przez reaktywny Nałogowiec (41,090 p.)
Uwaga Bantu jest sensowna, warto przeskoczyć z Winzgrozy na jakiś porządny OS.

Zaloguj lub zarejestruj się, aby odpowiedzieć na to pytanie.

Podobne pytania

0 głosów
0 odpowiedzi 310 wizyt
0 głosów
1 odpowiedź 388 wizyt
pytanie zadane 6 września 2016 w Ruby przez Szalbik Początkujący (430 p.)
0 głosów
2 odpowiedzi 1,469 wizyt

92,674 zapytań

141,575 odpowiedzi

320,045 komentarzy

62,038 pasjonatów

Motyw:

Akcja Pajacyk

Pajacyk od wielu lat dożywia dzieci. Pomóż klikając w zielony brzuszek na stronie. Dziękujemy! ♡

Oto polecana książka warta uwagi.
Pełną listę książek znajdziesz tutaj.

Akademia Sekuraka

Niedawno wystartował dodruk tej świetnej, rozchwytywanej książki (około 940 stron). Mamy dla Was kod: pasja (wpiszcie go w koszyku), dzięki któremu otrzymujemy 10% zniżki - dziękujemy zaprzyjaźnionej ekipie Sekuraka za taki bonus dla Pasjonatów! Książka to pierwszy tom z serii o ITsec, który łagodnie wprowadzi w świat bezpieczeństwa IT każdą osobę - warto, polecamy!

...