• Najnowsze pytania
  • Bez odpowiedzi
  • Zadaj pytanie
  • Kategorie
  • Tagi
  • Zdobyte punkty
  • Ekipa ninja
  • IRC
  • FAQ
  • Regulamin
  • Książki warte uwagi

Instalacja Symfony4

0 głosów
48 wizyt
pytanie zadane 27 maja w PHP, Symfony, Zend przez michal_php Bywalec (2,830 p.)

Cześć.

Mam pytanie bo instalując Symfony4 :

composer create-project symfony/website-skeleton my-project

instaluje mi się 3.4 i nie wiem co jest nie tak ?

komentarz 27 maja przez Arkadiusz Waluk Ekspert (249,210 p.)
Pokaż composer.json i/lub log z tego co się dzieje po wydaniu tego polecenia w konsoli.
komentarz 27 maja przez michal_php Bywalec (2,830 p.)
Microsoft Windows [Wersja 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. Wszelkie prawa zastrzeżone.

C:\Users\ibm>composer.json
Nazwa 'composer.json' nie jest rozpoznawana jako polecenie wewnętrzne lub zewnęt
rzne,
program wykonywalny lub plik wsadowy.

C:\Users\ibm>composer
   ______
  / ____/___  ____ ___  ____  ____  ________  _____
 / /   / __ \/ __ `__ \/ __ \/ __ \/ ___/ _ \/ ___/
/ /___/ /_/ / / / / / / /_/ / /_/ (__  )  __/ /
\____/\____/_/ /_/ /_/ .___/\____/____/\___/_/
                    /_/
Composer version 1.8.5 2019-04-09 17:46:47

Usage:
  command [options] [arguments]

Options:
  -h, --help                     Display this help message
  -q, --quiet                    Do not output any message
  -V, --version                  Display this application version
      --ansi                     Force ANSI output
      --no-ansi                  Disable ANSI output
  -n, --no-interaction           Do not ask any interactive question
      --profile                  Display timing and memory usage information
      --no-plugins               Whether to disable plugins.
  -d, --working-dir=WORKING-DIR  If specified, use the given directory as workin
g directory.
  -v|vv|vvv, --verbose           Increase the verbosity of messages: 1 for norma
l output, 2 for more verbose output and 3 for debug

Available commands:
  about                Shows the short information about Composer.
  archive              Creates an archive of this composer package.
  browse               Opens the package's repository URL or homepage in your br
owser.
  check-platform-reqs  Check that platform requirements are satisfied.
  clear-cache          Clears composer's internal package cache.
  clearcache           Clears composer's internal package cache.
  config               Sets config options.
  create-project       Creates new project from a package into given directory.
  depends              Shows which packages cause the given package to be instal
led.
  diagnose             Diagnoses the system to identify common errors.
  dump-autoload        Dumps the autoloader.
  dumpautoload         Dumps the autoloader.
  exec                 Executes a vendored binary/script.
  global               Allows running commands in the global composer dir ($COMP
OSER_HOME).
  help                 Displays help for a command
  home                 Opens the package's repository URL or homepage in your br
owser.
  i                    Installs the project dependencies from the composer.lock
file if present, or falls back on the composer.json.
  info                 Shows information about packages.
  init                 Creates a basic composer.json file in current directory.
  install              Installs the project dependencies from the composer.lock
file if present, or falls back on the composer.json.
  licenses             Shows information about licenses of dependencies.
  list                 Lists commands
  outdated             Shows a list of installed packages that have updates avai
lable, including their latest version.
  prohibits            Shows which packages prevent the given package from being
 installed.
  remove               Removes a package from the require or require-dev.
  require              Adds required packages to your composer.json and installs
 them.
  run-script           Runs the scripts defined in composer.json.
  search               Searches for packages.
  self-update          Updates composer.phar to the latest version.
  selfupdate           Updates composer.phar to the latest version.
  show                 Shows information about packages.
  status               Shows a list of locally modified packages, for packages i
nstalled from source.
  suggests             Shows package suggestions.
  u                    Upgrades your dependencies to the latest version accordin
g to composer.json, and updates the composer.lock file.
  update               Upgrades your dependencies to the latest version accordin
g to composer.json, and updates the composer.lock file.
  upgrade              Upgrades your dependencies to the latest version accordin
g to composer.json, and updates the composer.lock file.
  validate             Validates a composer.json and composer.lock.
  why                  Shows which packages cause the given package to be instal
led.
  why-not              Shows which packages prevent the given package from being
 installed.

C:\Users\ibm>

 

komentarz 27 maja przez Arkadiusz Waluk Ekspert (249,210 p.)
Nie doprecyzowałem, miałem na myśli albo plik composer.json, który Ci wygenerowało po zainstalowaniu Symfony albo log z konsoli po wydaniu create-project z pytania.
komentarz 27 maja przez michal_php Bywalec (2,830 p.)
{
    "type": "project",
    "license": "proprietary",
    "require": {
        "php": "^7.0.8",
        "ext-ctype": "*",
        "ext-iconv": "*",
        "symfony/console": "3.4.*",
        "symfony/dotenv": "3.4.*",
        "symfony/flex": "^1.1",
        "symfony/framework-bundle": "3.4.*",
        "symfony/yaml": "3.4.*",
      "ext-http": "*"
    },
    "config": {
        "preferred-install": {
            "*": "dist"
        },
        "sort-packages": true
    },
    "autoload": {
        "psr-4": {
            "App\\": "src/"
        }
    },
    "autoload-dev": {
        "psr-4": {
            "App\\Tests\\": "tests/"
        }
    },
    "replace": {
        "paragonie/random_compat": "2.*",
        "symfony/polyfill-ctype": "*",
        "symfony/polyfill-iconv": "*",
        "symfony/polyfill-php70": "*",
        "symfony/polyfill-php56": "*"
    },
    "scripts": {
        "auto-scripts": {
            "cache:clear": "symfony-cmd",
            "assets:install %PUBLIC_DIR%": "symfony-cmd"
        },
        "post-install-cmd": [
            "@auto-scripts"
        ],
        "post-update-cmd": [
            "@auto-scripts"
        ]
    },
    "conflict": {
        "symfony/symfony": "*"
    },
    "extra": {
        "symfony": {
            "allow-contrib": false,
            "require": "3.4.*"
        }
    }
}

 

1 odpowiedź

0 głosów
odpowiedź 27 maja przez Arkadiusz Waluk Ekspert (249,210 p.)
Jaką masz wersję PHP? Sf4 wymaga bodajże minimum PHP 7.1.
komentarz 27 maja przez michal_php Bywalec (2,830 p.)
7.0.33 jak zrobić update ?
komentarz 27 maja przez Arkadiusz Waluk Ekspert (249,210 p.)

Zależy jak masz je zainstalowane. Widzę że Windows, jeśli zainstalowałeś je samo możesz tu pobrać nowszą wersję: https://windows.php.net/download#php-7.3

Podobne pytania

0 głosów
1 odpowiedź 43 wizyt
pytanie zadane 27 maja w PHP, Symfony, Zend przez michal_php Bywalec (2,830 p.)
0 głosów
1 odpowiedź 73 wizyt
pytanie zadane 31 sierpnia 2018 w PHP, Symfony, Zend przez Q7V Gaduła (4,300 p.)
0 głosów
1 odpowiedź 75 wizyt
pytanie zadane 11 lipca 2018 w PHP, Symfony, Zend przez suice Gaduła (3,400 p.)
Porady nie od parady
Publikując kody źródłowe korzystaj ze specjalnego bloczku koloryzującego składnię (przycisk z napisem code w edytorze). Nie zapomnij o ustawieniu odpowiedniego języka z rozwijanego menu oraz czytelnym formatowaniu kodu.Przycisk code

65,654 zapytań

112,282 odpowiedzi

236,928 komentarzy

46,645 pasjonatów

Przeglądających: 147
Pasjonatów: 1 Gości: 146

Motyw:

Akcja Pajacyk

Pajacyk od wielu lat dożywia dzieci. Pomóż klikając w zielony brzuszek na stronie. Dziękujemy! ♡

Oto dwie polecane książki warte uwagi. Pełną listę znajdziesz tutaj.

...