• Najnowsze pytania
  • Bez odpowiedzi
  • Zadaj pytanie
  • Kategorie
  • Tagi
  • Zdobyte punkty
  • Ekipa ninja
  • IRC
  • FAQ
  • Regulamin
  • Książki warte uwagi

Problem z WLAN0 LINUX

0 głosów
80 wizyt
pytanie zadane 25 stycznia w Systemy operacyjne, programy przez zerakot Obywatel (1,550 p.)
Cześć,

Od jakiegoś czasu używam Linuxa w wirtualnym środowisku (VMware) wersja ubuntu. Kiedy wpisuję ifconfig/iwconfig to nie pokazuje mi się WLAN0. Próbowałem z "compact-wireless" i za którymś razem zadziałało, ale teraz nie chce zadziałać.

3 odpowiedzi

0 głosów
odpowiedź 25 stycznia przez adrian17 Mędrzec (178,320 p.)

Kontynuacja poprzedniego tematu:

Kiedy wpisuję ifconfig/iwconfig to nie pokazuje mi się WLAN0. 

A co się pokazuje? U mnie na przykład mostkowane połączenie z hostem pokazuje się pod nazwą enp0s3.

Powtórzę też wypowiedź z poprzedniego pytania, że zazwyczaj wirtualka nie powinna nawet wiedzieć o wifi. Wifi przejmuje się host który mostkuje połączenie do wirtualki.

komentarz 25 stycznia przez zerakot Obywatel (1,550 p.)
Nie za bardzo rozumiem... Wysłać ci SS z iwconfig/ifconfig?
komentarz 25 stycznia przez adrian17 Mędrzec (178,320 p.)
nie możesz wkleić tekstu (jako blok kodu w edytorze)?
komentarz 25 stycznia przez zerakot Obywatel (1,550 p.)

Skopiować w Linuxie i wkleić w Windowsie się nie da, więc wyślę SS

 

komentarz 25 stycznia przez adrian17 Mędrzec (178,320 p.)

Skopiować w Linuxie i wkleić w Windowsie się nie da

Da się jak się włączy odpowiednią opcję w wirtualizacji.

No i widzę eth0, wygląda dokładnie tak jak mówiłem - że host tuneluje połączenie na gościa i jesteście w jednej sieci lokalnej. Nie za bardzo rozumiem, co chcesz zrobić. Internet powinien działać, nie?

komentarz 25 stycznia przez zerakot Obywatel (1,550 p.)
Internet działa, ale ja chcę uzyskać wlan0
0 głosów
odpowiedź 25 stycznia przez PolYGlok Pasjonat (17,990 p.)
Nie będzie działać bo nie jest zapewne skonfigurowany interface sieciowy na który byś chciał. Więc system korzysta z ustawień hosta który udostępnia mu internet przez wifi ale mu o tym nie mówi a on go widzi jak przez kabel bo tak masz pewnie ustawione w virtualce (o które pytałem w poprzednim twoim temacie).
0 głosów
odpowiedź 25 stycznia przez Deloryn Bywalec (2,060 p.)
A próbowałeś ifconfig -a (albo: iwconfig -a)? Możesz mieć wyłączony ten interfejs i dlatego go nie widać normalnie. Wtedy musisz go włączyć

Podobne pytania

0 głosów
2 odpowiedzi 81 wizyt
0 głosów
1 odpowiedź 93 wizyt
0 głosów
0 odpowiedzi 174 wizyt
Porady nie od parady
Komentarze do pytań nie służą do odpowiadania, od tego jest wydzielona sekcja odpowiedzi. Funkcją komentarzy jest natomiast możliwość uzyskania dodatkowych informacji na temat samego posta.Komentarze

63,304 zapytań

109,563 odpowiedzi

228,872 komentarzy

43,893 pasjonatów

Przeglądających: 167
Pasjonatów: 7 Gości: 160

Motyw:

Akcja Pajacyk

Pajacyk od wielu lat dożywia dzieci. Pomóż klikając w zielony brzuszek na stronie. Dziękujemy! ♡

Oto dwie polecane książki warte uwagi. Pełną listę znajdziesz tutaj.

...