• Najnowsze pytania
  • Bez odpowiedzi
  • Zadaj pytanie
  • Kategorie
  • Tagi
  • Zdobyte punkty
  • Ekipa ninja
  • IRC
  • FAQ
  • Regulamin
  • Książki warte uwagi

Excel - kurs na YouTube; porównanie zawartości dwóch kolumn w poszukiwaniu zgodnych indeksów

Aruba Cloud PRO i VPS, Openstack, VMWare, MS Hyper-V
0 głosów
179 wizyt
pytanie zadane 11 kwietnia 2017 w Matematyka, fizyka, logika przez pejot88 Nowicjusz (120 p.)
edycja 12 kwietnia 2017 przez pejot88

Witam

Mój problem dotyczy Excela, mam listę wybranych produktów razem z indeksami i starymi cenami, oraz nową kompletną listę z nowymi produktami (tych jest znacznie więcej) z nowymi cenami. Potrzebuje porównać te dwie kolumny: jeżeli na nowej liście znajduje się indeks który jest również pośród moich produktów, to przechwycić przypisana do tego indeksu cenę.

Próbowałem z if, iferror, index/match, vlookup itd. Nic nie działa.

Przy okazji mała prośbą z mojej strony, czy na kanale na YT znajdzie się odrobina czasu i chęci na kurs Excela. Program niby każdy zna ale jestem pewien że zawsze się dowiemy czegoś nowego z takiego kursu, zawsze coś się uda wykorzystać. A nie jesteśmy przecież ręcznego wypełniania komórek, no ewentualnie kilkudziesięciu (a nie kilkudziesięciu tysięcy :)).

EDIT:

SOLVED. http://stackoverflow.com/questions/43344293/excel-product-list-price-update-based-on-a-bigger-list/43345812#43345812

komentarz 11 kwietnia 2017 przez pejot88 Nowicjusz (120 p.)
próbowałem między innymi:

=JEŻELI(LICZ.JEŻELI(P2:P44;Y2)=1;"OK";"NOK")

funkcja działa, podaje OK jeżeli Indeks jest na kompletnej liście ale potrzebuje jeszcze to rozwinąć o część w której zaciągnie nową cenę z sąsiadującej komórki

 

Podpowiedź ze stack overflow (narazie nie działa, czekam na poprawkę)

=IFERROR(INDEX($H$2:$H$3000,MATCH(D2,$I$2:$I$3000,0)),"NOK")

=JEŻELI.BŁĄD(INDEKS($H$2:$H$3000,PODAJ.POZYCJĘ(D2,$I$2:$I$3000,0)),"NOK")
komentarz 12 kwietnia 2017 przez jeremus Maniak (59,740 p.)
wyszukaj.pionowo  ?

Zaloguj lub zarejestruj się, aby odpowiedzieć na to pytanie.

Podobne pytania

0 głosów
2 odpowiedzi 166 wizyt
pytanie zadane 1 marca 2021 w Systemy operacyjne, programy przez hacerberry Użytkownik (670 p.)
0 głosów
1 odpowiedź 94 wizyt
pytanie zadane 10 kwietnia 2022 w PHP przez Bakkit Dyskutant (7,610 p.)
0 głosów
1 odpowiedź 119 wizyt
pytanie zadane 6 lutego 2020 w C# przez kubekszklany Gaduła (3,080 p.)

90,303 zapytań

138,899 odpowiedzi

311,089 komentarzy

60,019 pasjonatów

Motyw:

Akcja Pajacyk

Pajacyk od wielu lat dożywia dzieci. Pomóż klikając w zielony brzuszek na stronie. Dziękujemy! ♡

Sklep oferujący ćwiczenia JavaScript, PHP, rozmowy rekrutacyjne dla programistów i inne materiały

Oto dwie polecane książki warte uwagi. Pełną listę znajdziesz tutaj.

...