• Najnowsze pytania
  • Bez odpowiedzi
  • Zadaj pytanie
  • Kategorie
  • Tagi
  • Zdobyte punkty
  • Ekipa ninja
  • IRC
  • FAQ
  • Regulamin
  • Książki warte uwagi

Excel - sprawdzenie czy wybiła godzina!

0 głosów
58 wizyt
pytanie zadane 9 stycznia w Systemy operacyjne, programy przez użytkownika Andrzej Czarny Początkujący (350 punkty)

Cześć, potrzebuję pomocy w ogranięciu napisania warunku w excelu, sprawdzającego czy godzina podana w komórce A1 jest godziną aktualną. Jeśli tak, to 'ok', jeśli nie to 'czekaj'. Poniższe rozwiązanie nie działa:

=jeżeli(A1=godzina();'ok';'czekaj')

Z góry dzięki za pomoc. 

 

 

 

1 odpowiedź

0 głosów
odpowiedź 9 stycznia przez użytkownika playerony Stary wyjadacz (14,160 punkty)
wybrane 9 stycznia przez użytkownika Andrzej Czarny
 
Najlepsza

Potem możesz jeszcze dodać sekundy:

=IF( AND(HOUR(A1) = HOUR(NOW()) ; MINUTE(A1) = MINUTE(NOW()) ) ; "ok" ; "czekaj")

 

komentarz 9 stycznia przez użytkownika Andrzej Czarny Początkujący (350 punkty)

Dziękuję :)

=JEŻELI(ORAZ(GODZINA(A1)=GODZINA(TERAZ());MINUTA(A1)=MINUTA(TERAZ()));"OK";"CZEKAJ")

 

Podobne pytania

0 głosów
1 odpowiedź 29 wizyt
0 głosów
0 odpowiedzi 33 wizyt
pytanie zadane 19 grudnia 2016 w Systemy operacyjne, programy przez użytkownika Fosbiasz Początkujący (380 punkty)
0 głosów
1 odpowiedź 43 wizyt
pytanie zadane 2 grudnia 2016 w Systemy operacyjne, programy przez użytkownika InVictuS. Nowicjusz (120 punkty)
...